Kia Cadenza Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hello Fellow Cadenza owners, I am new to the forum..I would appreciate it very much if any of you can suggest a solution to my issues listed below.
I own a 2014 Cadenza Limited , and have a few issues which my dealer so far cannot fix.
When decelerating from about 20 to 30 mph, the tranny suddenly drops into a low gear , at that point the car starts slowing down and engine rpms go up. Then as the car is slowing down it suddenly upshifts and the car jerks forward.
Problem #2 the engine doesn't throttle down to idle when again decelerating . While the tranny is downshifting on its own , if I take my foot off the the brake pedal the car keeps going on its own, engine is going at 1200 RPM, car will keep going until I force it to stop by pressing harder on the brake pedal..allthis happens either at the same time or one at a time.After my tech adviser road tested the car is a busy section of brokklyn,NY full of traffic, he said he didn't see any problem, after pleading with him that maybe the contoller software needed to be upgraded, his mechanic took out an IPAD and said he was doing the update for everything, it took maybe 10 minutes time in all to complete.. I said thankyou and left the dealership, and of course the issues I mentioned are still there...Of all the cars I've ever owned I've had one that went into manual mode downshifted, nor a electronically sticking gas pedal... If anyone has any suggestions,kindly let me know before I go back to my Kia dealer. The dealer I purchased the car from closed down soon after I bought the cadenza, as he was shut down by KIA for too many sales shananigans.

Thanks to all:)

CP Brooklyn,NY
 

·
Super Moderator
Joined
·
898 Posts
Find a different KIA dealership. look for one ( on KIA web site)that is
certified to work on the K900, Or call the KIA hotline to ask for one.
Get car reset to factory specs. Takes special equipment to work on K900,
and cadenza
 

·
Registered
Joined
·
260 Posts
That's strange, yeah you could always try a different Kia dealership. When the car downshifts do you think its at the wrong time? Like the RPMS jump during the downshift? I know my Santa Fe Sport has a downshift braking function from 3rd to 2nd to help when braking but this occurs when you would expect a downshift to be made.

Find a different KIA dealership. look for one ( on KIA web site)that is
certified to work on the K900, Or call the KIA hotline to ask for one.
Get car reset to factory specs. Takes special equipment to work on K900.
The OP doesnt have a K900?
 

·
Registered
Joined
·
720 Posts
Without knowing anything about the software side of it, it just sounds like you're running too rich, or to high of an idle. That 1200 RPM is about what the startup RPM is until the car is warm. Normally too once you put it into gear before warm, it does drop a little, maybe to 1000rpm, but still feels more tension on the brake is needed to keep it from going forward to hard. But again, once warm the car is going to idle around 700 RMP all day, in or out of gear.


Not really any solution, just sharing how my 2014 seems to run, and what I perceive as normal behavior vs what yours seems to be doing.
 

·
Super Moderator
Joined
·
898 Posts
I think my Cadenza had to be reset to factory specs for the transmission shifting problem,
But didn't have the idle problem
 

·
Registered
Joined
·
796 Posts
I would definitely call the Preferred hotline and log an issue with them. They will get on the dealer to look at it more seriously. While my car will downshift while slowing down and it does feel like there is some breaking going on (fuel pump sending less gas in?) it's nothing dramatic and feels like normal to me, nothing jerky.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
Thanks for your reply, i will definitely call the hot line again...like I stated previously they said they upgraded the software, from an Ipad plugged into the data port under the dash drivers side. I asked if this was for the tranny and the mechanic who was helpful said it was for everything...This only took about 10 minutes, is that possible..Then my service advisor said I was done, didnt write up the service visit and said I'm not charging you... I reminded him that the car was still under warranty till december.
 

·
Super Moderator
Joined
·
898 Posts
Make sure you tell them just what you are saying here, when you call the hot line


Thanks for your reply, i will definitely call the hot line again...like I stated previously they said they upgraded the software, from an Ipad plugged into the data port under the dash drivers side. I asked if this was for the tranny and the mechanic who was helpful said it was for everything...This only took about 10 minutes, is that possible..Then my service advisor said I was done, didnt write up the service visit and said I'm not charging you... I reminded him that the car was still under warranty till december.
 

·
Registered
Joined
·
3 Posts
Hello Fellow Cadenza owners, I am new to the forum..I would appreciate it very much if any of you can suggest a solution to my issues listed below.
I own a 2014 Cadenza Limited , and have a few issues which my dealer so far cannot fix.
When decelerating from about 20 to 30 mph, the tranny suddenly drops into a low gear , at that point the car starts slowing down and engine rpms go up. Then as the car is slowing down it suddenly upshifts and the car jerks forward.
Problem #2 the engine doesn't throttle down to idle when again decelerating . While the tranny is downshifting on its own , if I take my foot off the the brake pedal the car keeps going on its own, engine is going at 1200 RPM, car will keep going until I force it to stop by pressing harder on the brake pedal..allthis happens either at the same time or one at a time.After my tech adviser road tested the car is a busy section of brokklyn,NY full of traffic, he said he didn't see any problem, after pleading with him that maybe the contoller software needed to be upgraded, his mechanic took out an IPAD and said he was doing the update for everything, it took maybe 10 minutes time in all to complete.. I said thankyou and left the dealership, and of course the issues I mentioned are still there...Of all the cars I've ever owned I've had one that went into manual mode downshifted, nor a electronically sticking gas pedal... If anyone has any suggestions,kindly let me know before I go back to my Kia dealer. The dealer I purchased the car from closed down soon after I bought the cadenza, as he was shut down by KIA for too many sales shananigans.

Thanks to all:)

CP Brooklyn,NY
My car has the exact same problem! Have you found the cause/sollution?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #11
Transmission and engine issues

I have not found a solution yet, The dealer reloaded software again, I told him he had to trigger the relearn function as well, by disconnecting the battery cable .
Of course it didn't help my problems......However the dealers personnel have been good to me and they keep telling me to come back if the problem still persists. I am calling the hotline again, to see if a tech person can call me back...
 

·
Registered
Joined
·
6 Posts
Have you been on Hyundai-forums.com? we have quite a few service techs on the Azera Forums. since our cars mechanically similar, it wouldn't hurt to ask people there. may be somebody had and fixed same issues with Azera.
 

·
Registered
Joined
·
93 Posts
I haven't had the issue described, but I did notice that my idle seems a little high when stopped. In rush-hour traffic, sometimes I just need to creep along at 1 or 2 mph, but my Cadenza wants to go faster.

I've figured out that if I pop it into neutral then back into gear, it'll then creep along happily at a slower speed. It seems that the brief change to neutral resets the idle to a lower speed.

Not sure if that'll help you any, as yours sounds like a real issue that needs tech support, but I wanted to share what I discovered in case someone finds it helpful.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #19
I took my cadenza to another dealer and they test drove it they said all the software is up to date , , they said the car drove normally and they didn't see any problem.. I recently purchased a can of throttle body cleaner as Luiz, is the previously post said that that was the fix, well I took all ducts out and I sprayed the cleaner into the the throttle body, but I did not want to force the throttle plate open, afraid I would strip the gears that drive the plate open and closed. Being that it is an E throtle assembly, However I road tested the car and low and behold the problem for the most went away, Does any one know the procedure for opening the throttle plate without starting engine?? Thanks to all
 

·
Registered
Joined
·
720 Posts
I just push it by hand with the car off...get in there with a rag soaked with Seafoam and whip out all the buildup. I do that every time I clean the K&N air filter, so once every 20,000 miles. Plate moves quite freely, and once you get all the buildup out of there it seals better.
 
1 - 20 of 23 Posts
Top