Kia Cadenza Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
343 Posts
Discussion Starter · #1 · (Edited)
When I drove to work this morning I noticed the attached screen display which I have not seen this before ( I think I never had) It is the Letter A followed by a few dashes and a icon of a car .I have no idea what that is nor if that is a danger sign or if I have something turned on that I am not aware of . Further complicating my morning and couldn't find anything in the drivers manual .Is this the normal display and if so what does the A stand for

UPDATE i AM AN IDIOT I had the trip A turned on by error I usually display the range .I must have touched the button on my steering when which controls the panel display:rolleyes:
 

Attachments

·
Registered
Joined
·
796 Posts
There seem to be a dwindling number of us. Honestly I don't know what I'll do here in a few months. My car has been at my dealer for 3 weeks tomorrow trying to get TSB148 done again (rattle is back) as well as get a new radio put into my car (screen issue though the screen is fine, it was radio). They so far haven't gotten a screen in for it (Kia wanted a used part to be searched for before they sent a new 1) and Kia engineers have denied my dealership doing TSB148 again stating the engine noise for 2-3 seconds on cold start up and "normal".

An escalation specialist called me a few days ago (I always get the premium line involved) trying to find out what is going on and why it is taking so long for the repair. I have since asked to be compensated since I haven't had my car for over month between my 2 warranty repairs so far. I will let you know when I get more info.
 

·
Registered
Joined
·
343 Posts
Discussion Starter · #5 ·
There seem to be a dwindling number of us. Honestly I don't know what I'll do here in a few months. My car has been at my dealer for 3 weeks tomorrow trying to get TSB148 done again (rattle is back) as well as get a new radio put into my car (screen issue though the screen is fine, it was radio). They so far haven't gotten a screen in for it (Kia wanted a used part to be searched for before they sent a new 1) and Kia engineers have denied my dealership doing TSB148 again stating the engine noise for 2-3 seconds on cold start up and "normal".

An escalation specialist called me a few days ago (I always get the premium line involved) trying to find out what is going on and why it is taking so long for the repair. I have since asked to be compensated since I haven't had my car for over month between my 2 warranty repairs so far. I will let you know when I get more info.
That is terrible I have been waiting for 6 weeks for my new radio ( Sirius issue) as my SAT radio has not worked from the day I picked up the car . The only rattle I have is my wife's hand lotion she keeps in the side door pocket ( why do women need hand lotion
 

·
Registered
Joined
·
796 Posts
I got a call from the dealer yesterday telling me my car was ready to pick up when I was able to get back to the dealer and that they tested it and drove it a round for a a while over the last 2 days. I told him that if it didn't mess up as soon as the car was turned on then it was ok and would not randomly fail while driven. About 5 minutes later I got a call back and he said after speaking with me he went to go test it 1 more time and the problem is back. He said they replaced the screen and 1 component that is apparently a couple grand. Now they are going to probably have to do the whole thing.

The thing that sucks about this (other than not having my car which I love) is that I'm in a Nissan Altima S. For those who may not know, that is the basic Altima. I don't want to sound like some pompus prick but it's really not what I have in mind to be in for a month+. I'm going to call today and see if they can get me into either something better or let me have an Enterprise car since this is a Kia warranty repair and they will pay for it. Does that sound like a dick move or is it somewhat justified? Also, when I got it the car smelled like someone delivered pizza in it and the window were filthy (still are, not my car I won't clean it, don't have time even if I wanted to).

And whether she NEEDS hand lotion or not, isn't it nice that her hands are nice and soft when you hold them?
 

·
Registered
Joined
·
803 Posts
Are you kidding...when they put me in a base model Cadenza for more then a day I feel like a rube. Miss my subwoofer, and all the Lux package components, even the rear sunshade. Yeah, you're entitled to a better car then a base Altama for a month, get you sum upgrade!
 

·
Registered
Joined
·
796 Posts
So I called them yesterday and asked for an Enterprise rental since it was a warranty repair and corporate will pay for it. We went to Enterprise and they gave me a choice of a Kia Soul, Chevy Sonic, and VW Jetta, so all compacts. I took the Jetta. Other than being the nicest looking one there I was honestly interested in driving a German car for a little. I think it has the little VW turbo'd motor in it. It's really quite efficient on gas too but will pick up and go if you hit the gas. It has a really odd mix of features in it too. Auto up/down windows for all windows, push button start, display (no nav), and sport mode shifter, but no dimming mirrors, seats are all manual adjust, lights are manual, no heater element on outer mirrors, and the speakers suck big ones.

All in all I guess I can say I'm happy with the trade up. If nothing else the car smells new and it is a lot cleaner than the dealer Altima although smaller. The car is fun but not the most comfortable thing. I may speak with my Kia escalation rep to see why they only allow compacts, it's not like I expect a luxury car or ****, maybe not even a full sized car, but a mid-size maybe? I dunno if I'll push it though.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top