Kia Cadenza Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Anyone else have rough idle at start. Just got car back from dealer for the second time, they have replaced injector 5 and 6. It still has a rough idle they say computer showed injector not firing right on over 200 occasions:(:(:(:( on the first time last last week. It feels like a cylinder is missing for about 20 seconds, rev the engine and it smooths out. Taking it back Monday with only 34000 miles and telling them to change plugs and start checking coil packs. They are not diagnosing very good or the whole injector rail system is bad!!
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Well three trips to dealer, 5 out of 6 injectors changed, 1 spark plug and a top engine flush to break up carbon done. Finally runs fairly smooth at startup. But I don't know if it won't do it again. Kia need to fix programming so the engine does not run so rich. They uploaded the newest software. But now I don't know if I can trust car to not have the problem again when out of warranty and cost an arm and leg to get repaired. It maybe hello toyota or Lexus again.
 

·
Registered
Joined
·
796 Posts
I've not experienced anything like this. Sucks, I take it this isn't the same thing as TSB 148?
 

·
Registered
Joined
·
796 Posts
Good point GrimReaper, there should be at least 1 entire thread around here somewhere (few years ago) that discusses this.

Also, our manual recommends that we use Chevron Techron fuel additive every 7k miles as part of standard maintenance.
 

·
Registered
Joined
·
2 Posts
How would using a gasoline additive help to clean the carbon from the valves.

My limited understanding of GDI engines is that the carbon accumulates on the valves because the gas is directly injected into the cylinder, not the airways and so the valves don't get washed by an air fuel mixture.

Seems like a gasoline additive would only clean the injectors in a GDI.

Thanks for the education.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #8 ·
Well several trips to dealer and its starting to miss a little again on startups, only use top tier gas and recommended Chevron cleaning additive every third tank. I have looked at all Cedenza's and Genysis on the road and all have black sooty tailpipes. Wife has had enough and I will be leaving this forum as we traded it last night for a 2016 Toyota Avalon. I had three of their 3.5's and never had any problems like this. Kia needs to get on the ball as this was a sporty nice car, but the motor just can't depend on it. Maybe they can throw a 2.0 turbo in it.
 

·
Registered
Joined
·
796 Posts
Sounds like he got a dud. Oh well, some people can't/don't want to work out problems. I get it's inconvenient but I wonder how big the hit was on trading it in like that so soon (I'm assuming).
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top