Kia Cadenza Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter · #1 ·
I rarely use my rear sun shade although I did when I first took ownership. When brand new, the operation of the shade was totally silent. The reason I've turned it off is when it completes the raising position, it makes a loud snap or clack sound . It is not hitting against anything; and my dealer says it is something in the base mechanism. They say they can only replace the screen and base mechanism and will do so, but, the entire rear package tray has to come out and probably the upper seat backs. Dealer said it is a lengthy repair which I interpreted to mean there could be secondary issues getting into all that disassembly. The side braces seem tight and firm, and, dealer says noise is in the lower unit which cannot be serviced; it has to be replaced.

The GM is a friend, as is the service advisor, so, while I believe that they believe that's what's needed, to me it just sounds like something somewhere needs tightening to prevent a loose joint from 'clacking' as it fully locks into place when raised. There is no similar noise when it lowers, only when it is finishing its rise into place.

Other than this annoying quick noise at the end of its raising, the shade works great so, I hesitate to have it replaced fearing rattles, squeaks, etc.

Anyone else have this same issue?

thanks in advance,
 

·
Registered
Joined
·
796 Posts
Just used mine last week after owning the car for over a yr (15 months, 5/14 build) and it works just fine. Nice and quiet.
 

·
Registered
Joined
·
782 Posts
I'd be willing to bet they are right about the lower assembly being a one shot deal; they gotta replace the whole thing as there aren't individual parts to replace or work on.
 

·
Registered
Joined
·
18 Posts
Mine is doing the same thing. The sound is worse for me on hot days. If it is cool, mine is quiet. Reminds me of the room crackle, it is at its worst on Hot days.
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #6 ·
14Cadenza, appreciate your posting your similar situation; have you talked to your dealer about it? So far, I'm not having any of the roof crackling noises and the body seems really tight and quiet. Course, I don't drive it often and have just turned 4000 miles after owning it since October 2013 ( retired ).

Appreciate a posting if anyone else has this issue, and 14Cadenza, please post if you have the dealer check yours.

Many thanks!
 

·
Registered
Joined
·
18 Posts
14Cadenza, appreciate your posting your similar situation; have you talked to your dealer about it? So far, I'm not having any of the roof crackling noises and the body seems really tight and quiet. Course, I don't drive it often and have just turned 4000 miles after owning it since October 2013 ( retired ).

Appreciate a posting if anyone else has this issue, and 14Cadenza, please post if you have the dealer check yours.

Many thanks!
I have not brought it up to the dealer yet, I am not a big fan of my dealer. I just had my backup camera replaced and it took two phone calls to Customer Care to get them to order the camera before I came in for service. They wanted me to leave the car twice, once to troubleshoot, and then go back to have the parts replaced, with no loaner. I pitched a bit of a fit and said the camera has water in it. It takes 20 minutes to replace, why does it need to be two visits with no loaner? Long story short they ordered the camera and replaced it within an hour. I have not wanted to bring this up because I am on the fence with finding a new dealer. They have been a bit of a pain since I got the car. Also after what you said I do not want my car torn apart to replace the part. :eek:
 
1 - 7 of 7 Posts
Top