Kia Cadenza Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
Well...here I am again with more problems with my awesome car :( When in reverse, the backup sensor do not work and beep at all. Seems to be a bad module and has to be replaced. Just letting everyone know what is wrong and hopefully no one else will experience this.

Wrong with my car so far:
- Side Mirror Metallic Rattle
- Sunroof Module Replacement
- Driver Side Fog Light Condensation
 

·
Registered
Joined
·
106 Posts
Sounds like you got a dud.

Are you sure you had your rear sensors turned on? The button is near the knee, you might have accidentally turned it off getting out the car one day or in.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #3
Interesting, I will have to check that out , didn't know there was a button. But the car is currently at the dealership. Yeah I'm thinking I got a DUD Cadenza, I'm having so many problems with the car. Now my Driver Side Mirror makes a loud motor sound when unfolding, also my rear tire has a air pocket in it (getting replaced for free). I had so many problems with this car so far that Kia Consumer Affairs is going to fix my Tire for Free and Pay One of my Monthly Car Payment under good will.

Wrong so far:
- Passenger Metallic Rattle in side mirror
- Dent in rear trunk behind placement of Cadenza Badge Wording, replace trunk lid back panel
- Sunroof Switch Replacement
- Driver Side Fog Light Replacement (Condensation)
- Driver Side Mirror Loud Motor sound when unfolding (currently at dealer)
- Air Pocket in Tire side wall (currently at dealer)
- Rear parking assist failure (currently at dealer)
 

·
Super Moderator
Joined
·
579 Posts
wow man... of all the Cadenza's that i've sold, ive heard of only the condensation in the fig light.. in fact mine has that. My volume control on the steering wheel also broke... getting those 2 things fixed.


Also on a side note... there is no button on Luxury Package to turn OFF the rear sensors.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #5
Thanks for the feedback! Yeah its crazy, I love the car but just not this Car, i'm having so much bad luck with this thing. The first time I bought a brand spanking new car too!!!! lol

Yeah I have the luxury Tech Package (Fully Loaded)
 

·
Super Moderator
Joined
·
579 Posts
i just researched this... the back up sensors will beep when you are close to an object... when you put in reverse, there is an initial "DING" or "CHIME" but will not beep until you are close to an object. Once you are the DIC will have a diagram that she's what area your sensors are picking up the object...

This diagram on the DIC is only on Luxury Pack and above... Premium doesn't have the LCD display
 

·
Registered
Joined
·
78 Posts
Discussion Starter #8
i just researched this... the back up sensors will beep when you are close to an object... when you put in reverse, there is an initial "DING" or "CHIME" but will not beep until you are close to an object. Once you are the DIC will have a diagram that she's what area your sensors are picking up the object...

This diagram on the DIC is only on Luxury Pack and above... Premium doesn't have the LCD display
Thanks for the input. Yes I know but on the LCD Screen all zones (green, yellow and red) all flash the whole time no matter what. Also, no beeping indications with objects occur at all! :(
 

·
Registered
Joined
·
1 Posts
Thanks for the input. Yes I know but on the LCD Screen all zones (green, yellow and red) all flash the whole time no matter what. Also, no beeping indications with objects occur at all! :(
Hi friend, I have the same problem. The LEDs (green, yellow, red) blinks and emits no sound. Managed to solve? If yes, how was it?
 

·
Registered
Joined
·
796 Posts
What LCD panel am I supposed to be missing on my Premium? From what I know I have everything except a few safety features.
 
1 - 11 of 11 Posts
Top