Kia Cadenza Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
193 Posts
Discussion Starter · #1 ·
Anybody have any issues with a popping noise coming from the front suspension?? I had my front two tires replaced recently and had a tire place look to see if they could find anything wrong with the suspension and they said everything is fine, however the popping noise is still there. The popping noise only seems to happen when you are accelerating or coming to a stop (<10 mph). I'll see if I can get a video of the noise
 

·
Registered
Joined
·
317 Posts
There are many reports of broken front springs in the '14 to '16 models, but this doesn't sound like that problem. Does it make a (normally described as clicking) noise when you have the steering wheel at full turn (lock) to the left or right while driving slow circles? That almost always indicates a bad joint in one of the half axles. Otherwise, it sounds like it could be one or more broken engine/transmission mounts. Beyond that maybe a transmission internal issue? That's just a guess that would take more time experiencing the sound/issue trying different gears and start stop, decel and accel situations.
 

·
Registered
Joined
·
193 Posts
Discussion Starter · #3 ·
I finally bit the bullet for the dealership diag ($190) and had them take a look at it, since two other places couldn't find anything wrong.... and the dealership found that it was just an axle nut not torqued to spec that was causing the popping noise. Luckily I didn't pay have to pay a dime at the two other places...
 
1 - 3 of 3 Posts
Top