Kia Cadenza Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
782 Posts
Discussion Starter · #1 ·
AC cooling works fine both sides, but I noticed today when running the front window de-foger at about 76, that heat is only coming out on drivers side, passenger side is either cool or cold. Only defrosted the drivers side was how I noticed it at first, then putting my hand up to right and left vents. I cycled through all the modes, turns out it's like that for every vent condition including floor heat. Dual zone on or off, outside vent or re-circulator, same outcome.

I have extended warranty so it should be covered. Was wondering if anyone experienced this and had it fixed, what caused it. 2014
 

·
Registered
Joined
·
237 Posts
I agree with Joegr. Many models of cars have suffered stuck/failed blend doors and the symptom is always one temp or the other (hot or cold) is the constant temp that never changes no matter what mode or requested temp but the other side of the car responds are requested temp wise.

I would arrange for dealer to fix. Any tech should be familiar with the problem/solution. Good that you have a warranty still as depending on the car/model it can get really expensive...usually more labor than parts.

Hope yours is covered!
 

·
Registered
Joined
·
782 Posts
Discussion Starter · #4 ·
Yeah, I've had 2 actuators replaced already, and was in a month ago told them i heard it making noise...asked them to find and fix it....they "couldn't duplicate". I'm a rip em a new one next time i'm in. The hood struts also just gave out, asked them to replace them a year ago, said they were weak. Add to it, yesterday with only about 180 miles into a full tank, turned on the car the damn gas gauge went to near empty. Gassed it up she only took 9 gallons and the gauge reset. They're gonna tell me they can't duplicate that, i'm gonna tell them bullshit, I told you it happened, you're taking my word, Actuator and hood struts I warned you about and now they are both broken...we gonna repair that gas float issue!
 

·
Registered
Joined
·
81 Posts
If it had gone to empty, it would have set a code in the cluster that they could verify. Maybe it did anyway.
 

·
Registered
Joined
·
237 Posts
The struts they may tell you is a wear item like brakes...be prepared...
 

·
Registered
Joined
·
81 Posts
Suspension struts I would agree are a wear item, though usually they should be covered up to 50K miles / 5 years. The hood struts I would expect to be under warranty. If not, they are cheap anyway, probably around $20 each.
 
1 - 7 of 7 Posts
Top