Kia Cadenza Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi everyone I'm new to the forums. We just leased a 2015 cadenza last week and so far I'm extremely happy with the car! The only issue I have is that 4 days after getting the car the leather above the steering wheel column on the dash has come loose like it separated from the glue. Has anyone else had this problem? This is my first time with a Kia and I'm a little concerned about the quality of the workmanship.
 

·
Registered
Joined
·
796 Posts
I've had mine for about 20 months so far and never had an issue like that, I would take it back to the dealer to have it looked at right away. I live in IN so I've left my car out in both 90/100+ temps and in -20 and below, never a rattle from the dash and nothing loose. Nothing should be loose up there either. The only real noise I hear is 1. startup rattle (TSB 148) which I'm having looked at this coming Monday (figures I don't hear it right now either), and 2. sounds like mild glass roof flex when there is a lot of snow/ice on it like this morning. Other than that your car really shouldn't make noise and NOTHING should be loose, even things that articulate shouldn't be.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Yeah I made an appointment for Friday to bring it in. Hopefully it's just a isolated random issue. Time will tell! ?
 

·
Registered
Joined
·
72 Posts
I'd say that's random. Never heard of that ever happening.

Maybe bad first impression for you, but it's a terrific car. Coming up on 30k miles in my 2014 Limited.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Not really a huge concern. I have the limited as well, and love this car! Never looked at KIA before. My buddy told me to go test drive one after I tried a Lexus. I was very impressed! This hasn't put me off, was just curious if anyone else had that issue.
 

·
Registered
Joined
·
115 Posts
35K Miles on my 2014 and the only problem so far was a bad rain sensor, replaced under warranty. Other than that have had zero issues. And no engine rattles or roof noise either!!
 

·
Premium Member
Joined
·
543 Posts
Welcome to the forum and congrats on getting your new ride.

As Gene mentioned, there is tons of useful info on this site.

If you have any questions or need assistance with customizing your new ride, don't hesitate to reach out to us here.

David
 

·
Registered
Joined
·
182 Posts
Almost 53k on my Cadenza, no issues other than the startup rattle which seems to be calming down, not noticing it as much...
Welcome to the forums brotha.
 

·
Registered
Joined
·
796 Posts
Almost 53k on my Cadenza, no issues other than the startup rattle which seems to be calming down, not noticing it as much...
Welcome to the forums brotha.
I have my car up at Kia this morning for an oil change and to look into the rattle under TSB-148. I will let you guys know what I hear back.
 

·
Registered
Joined
·
72 Posts
I have my car up at Kia this morning for an oil change and to look into the rattle under TSB-148. I will let you guys know what I hear back.
Are you talking about the rattle that only lasts like 3 seconds at the initial startup - then disappears right afterwards?

If that's the case, that's normal.
 

·
Registered
Joined
·
796 Posts
Are you talking about the rattle that only lasts like 3 seconds at the initial startup - then disappears right afterwards?

If that's the case, that's normal.
Yes I am talking about that. And no, no it is not normal nor is it supposed to happen. Hence why even Kia has finally put out a TSB on it.

As an update (like I promised) the master mechanic also has a Cadenza and knew immediately what I was talking. He heard it and ordered the parts for TSB-148. It is a warranty repair and will cost nothing. If this bothers anyone else I suggest you let them know during your next service you'd like them to look into it. The TSB is accessible to them through the Kiatechinfo site.

*Also, apparently we can still get to wiring diagrams and schematics of our car through the Kia customer area of the Kia website. Apparently you sign up for an account (with your VIN) and somehow navigate to that. It is similar to kiatechinfo but only for verified owners. I got this info from Cadenza preferred line and have yet to try it.
https://www.kia.com/us/en/owners/account/create
 

·
Registered
Joined
·
861 Posts
Yes I am talking about that. And no, no it is not normal nor is it supposed to happen. Hence why even Kia has finally put out a TSB on it.

As an update (like I promised) the master mechanic also has a Cadenza and knew immediately what I was talking. He heard it and ordered the parts for TSB-148. It is a warranty repair and will cost nothing. If this bothers anyone else I suggest you let them know during your next service you'd like them to look into it. The TSB is accessible to them through the Kiatechinfo site.

*Also, apparently we can still get to wiring diagrams and schematics of our car through the Kia customer area of the Kia website. Apparently you sign up for an account (with your VIN) and somehow navigate to that. It is similar to kiatechinfo but only for verified owners. I got this info from Cadenza preferred line and have yet to try it.
https://www.kia.com/us/en/owners/account/create

Whoever told you that is plain wrong. The only thing you can access is the stuff in your glovebox already - owner's manual, quick start guide, etc. No access to the shop manual stuff.
 

·
Super Moderator
Joined
·
902 Posts
yooshaw is right, The owners manual still says you can get kiatechinfo for free
it is not true. So no wiring diagrams or other info for free just glove box info.
false advertising
 

·
Registered
Joined
·
796 Posts
Ok, so the update I was promising on the TSB148 fix. My car was at the dealer for about a week because some parts had to be ordered from L.A. (apparently someone stole the last part from Chicago just before my order was put in lol). I asked them to also change my oil and do the 15k mi service so I really wasn't worried. What DID get was the fact that when I did get a rental Enterprise gave me a Fiesta... I'm not a big guy but my shin was resting on the center console near the shifter. I didn't mind because originally it was going to take 3 days. When I got the call stating it would probably be a week I told them I needed an upgrade. After some calls around between dealership and consumer affairs (rentals are taken care of by Kia, not dealership) I got an Altima as a loaner from the dealer that just got back in. I also got a call from the service manager saying that the 15k service would be $200 after my service plan was taken into consideration. That didn't sound right and after another call to consumer affairs it was taken care of and all in all everything was the normal $10 for just the Techron being added.

Sorry for the big wall there, here is the TSB148 portion. They said this job took about 9 hrs to do after all the parts were in. I think there were like 20 summod parts replaced. The car now starts VERY smooth and there is absolutely no rattle at all. This is exactly the way I would expect a car of our caliber to start. I highly recommend this service to anyone on their next standard service interval (beware parts may be limited and you may be without your car for a bit, so plan accordingly).

TL;DR
Kia consumer affairs did awesome for me again and TSB148 is worth it, my car starts great now.
 

·
Registered
Joined
·
16 Posts
Ok, so the update I was promising on the TSB148 fix. My car was at the dealer for about a week because some parts had to be ordered from L.A. (apparently someone stole the last part from Chicago just before my order was put in lol). I asked them to also change my oil and do the 15k mi service so I really wasn't worried. What DID get was the fact that when I did get a rental Enterprise gave me a Fiesta... I'm not a big guy but my shin was resting on the center console near the shifter. I didn't mind because originally it was going to take 3 days. When I got the call stating it would probably be a week I told them I needed an upgrade. After some calls around between dealership and consumer affairs (rentals are taken care of by Kia, not dealership) I got an Altima as a loaner from the dealer that just got back in. I also got a call from the service manager saying that the 15k service would be $200 after my service plan was taken into consideration. That didn't sound right and after another call to consumer affairs it was taken care of and all in all everything was the normal $10 for just the Techron being added.

Sorry for the big wall there, here is the TSB148 portion. They said this job took about 9 hrs to do after all the parts were in. I think there were like 20 summod parts replaced. The car now starts VERY smooth and there is absolutely no rattle at all. This is exactly the way I would expect a car of our caliber to start. I highly recommend this service to anyone on their next standard service interval (beware parts may be limited and you may be without your car for a bit, so plan accordingly).

TL;DR
Kia consumer affairs did awesome for me again and TSB148 is worth it, my car starts great now.
If I may ask - what dealer was this? I'm in the Chicago area too and have only dealt with one dealer so far. Not impressed with the initial results.
 

·
Registered
Joined
·
796 Posts
Butler Kia of Indianapolis, just on the North side of 465 off Meridian. It would be about a 3 hour drive for you or thereabouts. I wouldn't say I was "impressed" with them as much as they are seem to be the only half way competent Kia dealer in the Indianapolis area. I won't go to Ray Skillman at all even though the dealership is bigger and possibly a bit nicer the employees are terrible, never found out about their service dept. but I won't chance it. I would say Butler is about average of what I expect from a car dealer, nothing to write home about but nothing to scare me away like Skillman.
 

·
Registered
Joined
·
782 Posts
I had the exact same rattle in my Maxima, had it serviced under warrantee (3rd party) twice, had the car for about 2 days each time. Second time they damaged the head, could never get the valve cover to seal so I was smelling oil for about a year. took it in 7 times for them to resolve, they never got it, finally just traded her in for the Cadenza. I'm a little gunshy to have the exact same service done on the car, even though the rattle is annoying.


Oh, to make matters worse with the Maxima, they never really got rid of the rattle at startup. It got quiet for a week or so after the service, then came back. I'd be interested to see how yours is after a month of stops and starts. Please report back with any updates...
 

·
Registered
Joined
·
796 Posts
Will do. If I remember correctly this is something to do with timing. Changed out some actuator whatsits and other bits. We will see. I think a tiny bit is natural just as everything is firing up to life, not like what was going on though that everyone has reported on.
 
1 - 20 of 23 Posts
Top