Kia Cadenza Forum banner
1 - 10 of 10 Posts

·
Super Moderator
Joined
·
911 Posts
Didn't think there was a regular intermittent. I thought first pull down was auto, second notch down is slow, and last notch is fast. Auto sensitivity is controlled by the dial.

Checking fuses is good, and there are two relays to check as well - one for the rain sensor and one for wiper control. If it's still under warranty, I'd have the dealer check it out though.
 

·
Super Moderator
Joined
·
911 Posts
Swive -

Take a look at Page 7-67 and 7-68 in the Owner's Manual - that shows where the two fuses (one under the dash, another under the hood) and two relays are (under the hood). If the two fuses are good, I'd check the relays next.

Since your wipers are working (just not auto/intermittent), we can assume something is wrong with the rain sensor. Try switching the horn relay with the rain sensor relay to see if that fixes it (assuming these relays are identical, compare pins to make sure). Otherwise, there maybe something wrong with the rain sensor itself or the stalk.
 

·
Registered
Joined
·
115 Posts
Discussion Starter · #6 ·
Thanks for the suggestions fellas...
I got an early appointment Friday am so I'm bringing her to the dealer.
Maybe I can get them to clean the soot off my white bumper as well.
(And yes, I've been using Techron. Driving in the rain seems to make the soot build up significantly worse.)
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top