Kia Cadenza Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
2014 Cadenza Premium with 50K miles.

Twice (within the past 2 months), I have turned the car off and realized that the fan has kept running.

On both of those occasions, it was quite warm outside, but not warm enough to warrant this behavior.

When this happens, turning the car on and back off again (multiple times - usually 3-4 times) eventually gets the fan to stop.

I am taking the car into the dealership next week for diagnosis, although the issue happens intermittently making it almost impossible for the dealer/mechanic to duplicate the problem, so I am not too optimistic.

Ideally, this could be a simple case of a sticky relay or something that can be easily replaced.

Any Cadenza owner been through this before?

Feeling quite frustrated :(
 

·
Registered
Joined
·
133 Posts
The fans tend to stay on for a few minutes (i’ve recorded up to 7 or 8 minutes before) when your coolant gets warm enough, exterior temperature doesn’t seem to matter. Is it possible you’ve been driving hard or idling for long periods of time?
 

·
Super Moderator
Joined
·
902 Posts
Years ago cars would boil over after getting up to running temperature and being shut off.
Auto makers realized the water in the engine was still extremely hot and there was no air
going thru the radiator to cool it down. So they added temp controlled fans in order to cool
the water still going thru the radiator. It is normal, just the Cadenza fan is makes more noise
than some fans
 

·
Registered
Joined
·
179 Posts
@Alan14 this is normal behavior...for most cars even, but definitely for ours. Mine does it mostly after having my AC running in warmer temps then parked and shut off. Most times I barely even notice it because it's just running a slow speed, not even a medium or high speed. When the car is idling in the driveway with the AC on, the fan is usually running at a medium speed. What I'm referring to after the car is off, is much slower and quieter than that. Totally normal behavior, don't waste your time going to the dealer.
 

·
Registered
Joined
·
762 Posts
It's not uncommon. It's not necessarily about the heat outside, but the heat inside. Even if it's only 90 outside, if you've been sitting still in traffic, or a lot of stop and go, that's enough to keep the fans on.
 

·
Registered
Joined
·
20 Posts
Mine did it for the first time and ran my battery down this weekend. Hope it's a one off situation and not a trend. (2014/30k miles)
 

·
Registered
Joined
·
133 Posts
Mine did it for the first time and ran my battery down this weekend. Hope it's a one off situation and not a trend. (2014/30k miles)
How long did it run? If it was able to kill your battery then either it’s a problem with your battery or it ran too long
 

·
Registered
Joined
·
20 Posts
Well the clock stopped at 1:00. I parked it at 11:15. So possibly hour and 45 minutes. Battery was dead when I got back. Had AAA jump it off and test battery. Battery tested fine and has held charge since then. So, I'm hoping the fan running too long is just a one off problem.
 

·
Registered
Joined
·
133 Posts
Well the clock stopped at 1:00. I parked it at 11:15. So possibly hour and 45 minutes. Battery was dead when I got back. Had AAA jump it off and test battery. Battery tested fine and has held charge since then. So, I'm hoping the fan running too long is just a one off problem.
yeah that does sound odd, i’m sure it’ll just be a one time glitch though.
 

·
Registered
Joined
·
762 Posts
I'd get that checked out. That actually is likely a common problem, some relay or perhaps the fans themselves. But I wouldn't take a chance that it does it again. When I said before it is not uncommon for fans to run , I meant for just a few minutes after, not like this for sure!
 

·
Registered
Joined
·
20 Posts
MadMax you are correct I am definitely keeping an eye on it and will get it to the shop if it happens again. Do you or zjuretich have the panoramic sunroof? I know there is another thread on this but i thought i would ask you two if you do have the sunroof does it creak? I saw a Tsb for the OPTIMA and was wondering if this remedy would be worth taking to the dealer and getting them to try.
 

Attachments

·
Registered
Joined
·
133 Posts
MadMax you are correct I am definitely keeping an eye on it and will get it to the shop if it happens again. Do you or zjuretich have the panoramic sunroof? I know there is another thread on this but i thought i would ask you two if you do have the sunroof does it creak? I saw a Tsb for the OPTIMA and was wondering if this remedy would be worth taking to the dealer and getting them to try.
Yeah i’ve got the sunroof and it creaks like no other. Unfortunately i’m out of warranty so they won’t do anything for me without my wallet getting significantly lighter. I’ve just learned to live with it. One of these days i’m going to find the exact spot it’s rattling and get a needle and inject some glue up in that spot. that’s a long ways away though, if it’s even possible.
 

·
Registered
Joined
·
20 Posts
Yeah, I’ve got the sunroof and it creaks like no other. Unfortunately i’m out of warranty so they won’t do anything for me without my wallet getting significantly lighter. I’ve just learned to live with it. One of these days i’m going to find the exact spot it’s rattling and get a needle and inject some glue up in that spot. that’s a long ways away though, if it’s even possible.
I emailed Kia motors and they said if i would get an estimate from the dealer and send it to them they would probably pay for some of it. I'll believe it when it happens but I'm going to give it a shot. I'll keep ya posted.
 

·
Registered
Joined
·
133 Posts
I emailed Kia motors and they said if i would get an estimate from the dealer and send it to them they would probably pay for some of it. I'll believe it when it happens but I'm going to give it a shot. I'll keep ya posted.
Sounds good, I’d like to know how much it would cost as well, maybe i’ll decide to do that eventually. Calling Kia preferred line might provide some decent results as well, just a suggestion.
 

·
Registered
Joined
·
11 Posts
Happened to me last year on my '15 - fan would run and not shut off (killing the battery once). Dealer replaced both the high and low fan relays (under warranty) because apparently its a know problem they can stick.
 

·
Registered
Joined
·
24 Posts
Old thread but I had the same issue in my 2015, fans kept running to the point of killing the battery. It started in early 2019 and became more frequent as the year dragged on. Finally in December after getting stranded at the gym I decided to replace the original Kia battery. 9 months have passed and not once have the fans run after shut off.
 

·
Registered
Joined
·
24 Posts
Old thread but I had the same issue in my 2015, fans kept running to the point of killing the battery. It started in early 2019 and became more frequent as the year dragged on. Finally in December after getting stranded at the gym I decided to replace the original Kia battery. 9 months have passed and not once have the fans run after shut off.
Just over a year later and the fan started to stay on again. This time I pulled the fan relay and found that it was over heated enough to show burn marks on it. I replaced it with OEM, fingers crossed. PS. buy one on Amazon, it will be half the dealer cost.
 

·
Registered
Joined
·
13 Posts
Just over a year later and the fan started to stay on again. This time I pulled the fan relay and found that it was over heated enough to show burn marks on it. I replaced it with OEM, fingers crossed. PS. buy one on Amazon, it will be half the dealer cost.
Any update? Did the new relay solve your problem?
 
1 - 20 of 21 Posts
Top