Kia Cadenza Forum banner

1 - 11 of 11 Posts

·
Super Moderator
Joined
·
902 Posts
Discussion Starter #1
Has anyone had a problem with the Auto AC?
Wife and I took an 1824 mile trip from Glendale Arizona up the Calif. coast to San Francisco and back. 6 hours in to the trip I had sweat running off my glasses and down the back of my neck. Auto AC turned the fan down to the lowest setting. It was 106 and couldn't till it gets to 98 or 99the car cool. Turned AC off for 5 minutes and then back on worked for 2 or 3 minutes then lowered fan to useless again. This played over and over. I was able to turn the AC on and control the fan manually, but had to turn fan up and down as needed. Pain in the butt. We finally cut our vacation short and came home. The AC now works until it gets to 98 or 99 then cuts out after 2 hours driving. Only 7200 miles and will take it in to have it checked tomorrow.. Dealer will probably tell me they can't duplicate the problem and I will have the same thing happen next trip. Will work now for a short trip then after about 2 hours cuts out.
 

·
Registered
Joined
·
25 Posts
Interesting, same thing happened to my friends taking my car to KC (about 6 hr drive) a couple of weeks ago, exact same thing, we attributed it to my friends iphone kept buzzing when he plugged it in, on the way back, nothing plugged in and worked flawlessly. Please let us know what your dealer finds out.
 

·
Super Moderator
Joined
·
902 Posts
Discussion Starter #4
Got back from dealer today on the AC problem. They were unable to get the AC problem to show up. I explained to them that it only happened when it was really hot out ,106 is hot . It also only happened after running for 2 hours or more. So quess I will have to wait till next trip, Then stop at a kia dealership and not turn the car off before they check it out.
 

·
Super Moderator
Joined
·
902 Posts
Discussion Starter #6
I thought it might be freezing, but I can still operate it on manual. It is only the auto mode that the fan stops working.
 

·
Registered
Joined
·
194 Posts
It seems like some sensor. Wonder what it is. I would think that the sensor malfunctions in the heat.
 

·
Super Moderator
Joined
·
902 Posts
Discussion Starter #8
sensor or control unit, but kia will not replace unless I can take it to them when it is acting up
It will do it on our next trip.
 

·
Registered
Joined
·
1 Posts
I was helping by AC SERVICE CYPRESS to troubleshoot non-functioning AC in her 2008 Volvo S60. I determined that the AC relay is functional but for whatever reason the computer isn't ever sending the signal to activate the compressor (the signal going to the relay holds at a steady 9.5V regardless of the AC setting). By replacing the relay with a jumper I was able to show that the AC system does in fact work. A mechanic had previously determined that there was no problem with the refrigerant levels and that the problem was electrical, but the engine compartment appears to be too compact for me to access the pressure switches.
 
1 - 11 of 11 Posts
Top