Kia Cadenza Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
I just did a trip from Virginia to Ohio, and where I had one small chip in the paint in the front bumper, now I have many. Even one on the hood. I've never had a car chip up this fast; ****, my 2010 Dodge Charger hasnt got a chip in the front at all. I had thought about getting a clear bra for the front, now I'm kind of regretting it.

Also, I had noticed a creaking sound which I think I have isolated to the hood. They had to adjust the hood on it because on the passenger side it was clearly misaligned. Today was the first time I washed it since this was "fixed", and just pressing slightly in that area I could reproduce the sound. Going to have them take a look at it next week when they will be replacing the rear passenger side quarter window trim (it deformed).

I REALLY love this car, but I'm starting to get annoyed with these little issues. Now with the recall on the rims...I just dont know
 

·
Registered
Joined
·
13 Posts
I also have the "creaking sound" in my hood on the passenger side. I noticed this today when I was washing the hood. Paint chips on the car but we have a lot of construction in the Houston area so don't notice anymore than what I have had on other cars. I had the clear bra on my Nissan Maxima and it protected the front end very well. I thought about getting it on this car but I could not justify the $700 on a lease car.
 

·
Registered
Joined
·
106 Posts
Going to have the paint issues with any car these days. You were just lucky with the charger, unfortunately with the new paint regulations they're all cheap and useless.

As for the rest of the problems, good for you for staying on top of them. Remember the lemon law and look it up. I just had to go through the lemon law process for a 2014 Taurus SHO. My Cadenza is still running strong, even though she's only got 3100 miles on her after one year.. lol
 

·
Registered
Joined
·
135 Posts
Your braking brake isn't working? wow you just got a unlucky one. I have noticed a creaking sound from my compartment where the charging cable is anyone else notice that? Also I have floored my car a couple times and once it gets to 40 mph it just slushes and doesn't keep going? anyone notice that?
 

·
Registered
Joined
·
106 Posts
Your braking brake isn't working? wow you just got a unlucky one. I have noticed a creaking sound from my compartment where the charging cable is anyone else notice that? Also I have floored my car a couple times and once it gets to 40 mph it just slushes and doesn't keep going? anyone notice that?
Nope, mine pulls until I stop flooring it.

The car is creaking.

Depends on the symptoms of your electronic parking brake not working any more. It doesn't work in certain situations.
 

·
Registered
Joined
·
14 Posts
I have 2100 miles on mine so far and have none of the issues described above. In fact, there are no issues whatsoever (knock on head).
Loving every minute in my Cadenza.
 

·
Registered
Joined
·
78 Posts
I have so many paint chips on the front of my car its ridiculous, car looks like a 4 year old used model. On top of that, I'm having so many issues with this car, its been in the shop at least every month since I had it, working on a Lemon Law Case as we speak. Very VERY VERY DISAPPOINTED IN THIS CAR!!!!
 

·
Super Moderator
Joined
·
902 Posts
murrwin
Sorry to hear you have more problems by all means pursue the lemon law.
Every make of car has some of those, sorry you got one. If you get an offer to move to a new cadenza, wait for the 2015, I've heard there are some changes. Nothing big but some little things corrected.
Knock on wood I've had no problems with mine other than the back up camera staying in night mode, the update took care of that, and the wheel recall. they are replaced now. My only complaints were the things they left off on the first cadenza's like the passenger seat air.
Good luck with the lemon law let us know how you make out. some times you just have to make lots of noise to be heard
 

·
Registered
Joined
·
9 Posts
I am with gene. I love my car still and have right at 13k miles. Wish I had the passenger cool air, but nothing major wrong.

Only two minor issues is my compass blinking in the mirror and my HUB size setting doing nothing when I change it within the settings even after the update.

Just got my leather conditioned and it looks like I just drove it off the lot.
 
1 - 16 of 16 Posts
Top