Strange cruise control behavior - Kia Cadenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 01-17-2020, 01:05 PM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Strange cruise control behavior

Hi group,


Bought a 2019 Cadenza a few months ago. The cruise control behavior is odd. It sets fine, and one second bump ups and downs with the switch works fine, resulting in 1 mph increases and decreases respectively. But when you have it set and hold the switch in the down position, to say, slow the car by 10 mph then release it, it doesn't reset at that speed. Pressing down again quickly to get it to set at the desired speed, nothing happens, the car continues to slow. Same in the up position in the reverse sense. If you hold it in the up position to increase speed by say, 10 mph, then release it the car keeps on gaining speed and does not stop when the switch is released. The only fix is to turn off the cruise control and start over. BTW, I don't have the smart cruise control.


Any idea for this behavior? Has anyone experienced this with their Cadenzas? Never had another car that this has happened with. Something in the ECU perhaps? Thanks for responses.
Ferdy is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-09-2020, 12:17 PM
Member
 
iaw94117's Avatar
 
Join Date: Mar 2019
Location: El Mirage, AZ.
Posts: 55
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Garage
I've never used the cruise control in this manner, I set it and forgot about it. Why would you want to use cruise control and then increase/decrease the speed by a large margin suddenly? If traffic slows down you apply your brake, then when traffic picks up again you hit the resume button.
iaw94117 is online now  
post #3 of 4 (permalink) Old Yesterday, 07:56 AM
Senior Member
 
Join Date: Oct 2014
Posts: 708
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 157 Post(s)
Not sure why you wouldn't adjust speed using the the method described the the OP. That said, it does sound weird. You should be able to decelerate, letgo, and it picks up right at the new new speed. Sounds like a warranty question at the dealership?
MadMax is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old Yesterday, 11:40 AM
Senior Member
 
Join Date: Jul 2015
Location: Vancouver BC
Posts: 336
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 67 Post(s)
Quote:
Originally Posted by Ferdy View Post
Hi group,


Bought a 2019 Cadenza a few months ago. The cruise control behavior is odd. It sets fine, and one second bump ups and downs with the switch works fine, resulting in 1 mph increases and decreases respectively. But when you have it set and hold the switch in the down position, to say, slow the car by 10 mph then release it, it doesn't reset at that speed. Pressing down again quickly to get it to set at the desired speed, nothing happens, the car continues to slow. Same in the up position in the reverse sense. If you hold it in the up position to increase speed by say, 10 mph, then release it the car keeps on gaining speed and does not stop when the switch is released. The only fix is to turn off the cruise control and start over. BTW, I don't have the smart cruise control.


Any idea for this behavior? Has anyone experienced this with their Cadenzas? Never had another car that this has happened with. Something in the ECU perhaps? Thanks for responses.
Do you have adaptive speed control if so then adjust your car lengths to the lower one .That might solve the issue .
funnyman7915 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome